Index Forum Généamania
Tout sur Généamania et monSSG
Faq  -   Se connecter  -   S'enregistrer  -   Liste des membres   -  Rechercher  



Vous ne pouvez pas poster de nouveaux sujets dans ce forum Vous ne pouvez pas poster de réponses
Màj V6.6 un peu difficile
Auteur Message
zazou120



Autorisation : Membre
Nb de messages : 45
Inscrit le : Jeu 06 Aoû 2009, 15:47
Posté le : Jeu 19 Nov 2015, 0:03    

Bonjour,

J'essaye de me connecter à ma base sur le site de free et j'ai ce message d'erreur :
Echec de la connexion à la base de données !could not find driver

Infos venant de free.fr
Les paramètres de connexion à la base de données MySQL sont les suivants :

Host : sql.free.fr
User : Votre_login
Pass : Votre_mot_de_passe
Base : Votre_login


Voici aussi ce que m'affiche la page index.php qui me permet d'aller dans install.php

Echec de la connexion !could not find driverVérifiez votre connexion via la page d'installation.
Bienvenue sur le site de généalogie de
Conseil Pensez à paramétrer votre site dans le menu "Gestion du site""

Stop Incohérence dans la version (6.6 vs. ), veuillez procéder à une migration de la base.
Migration disponible ici


Ch G

 Adresse email Haut de page Bas de page 
 
jlsviro



Autorisation : Administrateur
Nb de messages : 1686
Inscrit le : Dim 23 Avr 2006, 16:17
Posté le : Jeu 19 Nov 2015, 11:11    

Bonjour,

Le sujet avait été évoqué il y a quelque temps ici http://forum.geneamania.net/sujet.php?sujet=643.

Free ne supportait pas PDO...

Cependant, la situation a évolué depuis happy.gif

En effet, la version de PHP n'est plus bloquée en 5.1.3, puisque la 5.4 est disponible (Cf. https://forum.online.net/index.php?/topic/2939-beta-disponibilit%C3%A9-de-php-54/). J'ignore cependant si PDO MySql est disponible sur cette version.
De plus, une 5.6 est actuellement en test, qui elle, supporte PDO MySQL. Je ne sais cependant pas si Généamania supporte la 5.6 crazy.gif

Quelle est votre version actuelle de PHP ? Que dit le support Free sur le support de PDO ?

Bonne journée.

jean-Luc

 Adresse email Haut de page Bas de page 
 
zazou120



Autorisation : Membre
Nb de messages : 45
Inscrit le : Jeu 06 Aoû 2009, 15:47
Posté le : Jeu 19 Nov 2015, 23:07    

Bonjour,

Je viens de tester sur le site de free quelle version est dispo:
Version PHP courante : 5.1.3RC4-dev.

Je ne sais pas trop où aller voir pour avoir une réponse pour le support PDO. Pourriez-vous m'indiquer comment faire ?

Ch G

 Adresse email Haut de page Bas de page 
 
xianmai



Autorisation : Membre
Nb de messages : 92
Inscrit le : Sam 11 Juil 2009, 15:26
Posté le : Ven 20 Nov 2015, 16:50    

Bonjour,

J'utilise également Généamania v6.6 sur mon site Free et cela fonctionne très bien ; actuellement la version php 5.6.8 est en bêta test chez Free et elle intègre le driver PDO ; pour l'activer, on doit mettre un fichier .htaccess à la racine du site contenant les lignes suivantes :
#PHP v5.6.8
<IfDefine Free>
php56 1
</IfDefine>

En l'absence de ce fichier, c'est la version php 5.1.3RC4 qui est active : cette version n'intègre pas le driver PDO.

Cordialement

Christian

 Adresse email Haut de page Bas de page 
 
zazou120



Autorisation : Membre
Nb de messages : 45
Inscrit le : Jeu 06 Aoû 2009, 15:47
Posté le : Mar 24 Nov 2015, 0:31    

Merci beaucoup cela fonctionne. ahh.gif

 Adresse email Haut de page Bas de page 
 
Vous ne pouvez pas poster de nouveaux sujets dans ce forum Vous ne pouvez pas poster de réponses






  Powered by Fire-Soft-Board v1.0.10 © 2004 - 2017 Groupe FSB
Page générée en 9 requêtes